Powered by Invision Power Board


  Reply to this topicStart new topicStart Poll

> 404 and 200 Configuration
aboatman
Posted: Mar 12 2006, 08:13 PM
Quote Post





Group: Members
Posts: 24
Member No.: 173
Joined: 8-January 03



I am trying to get setup on the Google Sitemaps. Their system will not allow me to verify the sitemap due to the 200 in the header of my 404 file. I am not sure what this is but figured it was a Plesk created item. Can you see the information below and enlighten me as to what I need to do?

We've detected that your 404 (file not found) error page returns a status of 200 (OK) in the header.
This configuration presents a security risk for site verification and therefore, we can't verify your site. If your web server is configured to return a status of 200 in the header of 404 pages, and we enabled you to verify your site with this configuration, others would be able to take advantage of this and verify your site as well. This would allow others to see your site statistics. To ensure that no one can take advantage of this configuration to view statistics to sites they don't own, we only verify sites that return a status of 404 in the header of 404 pages.

Please modify your web server configuration to return a status of 404 in the header of 404 pages. Note that we do a HEAD request (and not a GET request) when we check for this. Once your web server is configured correctly, try to verify the site again. If your web server is configured this way and you receive this error, click Check Status again and we'll recheck your configuration.

Thanks,
Andy
PMUsers WebsiteYahoo
Top
Matt
Posted: Mar 13 2006, 08:16 AM
Quote Post





Group: Members
Posts: 1,103
Member No.: 342
Joined: 25-November 03



You have chosen the option "Apache Error Documents" when you configured the domain in Plesk. This option changes the way the server returns error codes. To provide the response Google Sitemaps is looking for you will need to turn the custom error documents feature off for your domain with the following steps:

1) Log into the Upipe Plesk 5 control panel.
2) Click on the domain for which you need to turn off the custom error documents.
3) Click on the Hosting button.
4) Click on the Next button.
5) Uncheck the box next to "Apache Error Documents".
6) Click on the Update button to save your changes.

It will take up to an hour for these changes to take place.


--------------------
Matt B.
Advantagecom Technical Support

Private messages are ignored unless solicited. If you have a support question, please email support@advantagecom.net, post in the appropriate section of the forum, or call if your service plan allows support by phone.
PMUsers Website
Top
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll