Powered by Invision Power Board


  Reply to this topicStart new topicStart Poll

> 404 error so strange, checkout.pl generates a 404 error???
nels
Posted: Dec 16 2003, 05:58 PM
Quote Post





Group: Members
Posts: 44
Member No.: 341
Joined: 22-November 03



Any ideas on this?
This was working at my old ISP...I have moved all my sites to you and am HAPPY if only I could get this perl to run again. You guys are great

It is the last step in a shopping cart. Checkout.pl is in cgi-bin and I have set perl correctly and permissions are 755 and I made sure to convert to Unix before uploading. normally, if it is a text issue I get a 500 error.

Let me know
URL www.stone-reflections.com
This is a u-pipe account on Plesk.


--------------------
PMEmail Poster
Top
andy
Posted: Dec 17 2003, 07:41 AM
Quote Post





Group: Advantagecom Staff
Posts: 4,340
Member No.: 9
Joined: 12-July 02



When you first login to your FTP account on a Plesk based account, you'll see several folders. Two of those folders are httpdocs and cgi-bin. In order for something to be referenced at http://www.stone-reflections.com/cgi-bin/somefile.pl , it has to be in the cgi-bin folder I just mentioned.

Note that this is easily confused with placing a folder called cgi-bin in the httpdocs or httpsdocs directory, which will not work.


--------------------
Sincerely,
Andrew Kinney
CTO, Advantagecom Networks

Please do not private message me. My regular management duties preclude responding to every customer that sends me a support issue. Instead, post on the forum or contact tech support.
PMUsers Website
Top
nels
Posted: Dec 17 2003, 09:29 AM
Quote Post





Group: Members
Posts: 44
Member No.: 341
Joined: 22-November 03



Andy,
Thanks for the fast answer, I really appreciate it!

So can I assume if I want to use my installed SSL certificate I need to put files in the https directory to be seen.

My plan for carts is to get my current java based cart running again (nopcart) and then in the future replace it with a more robust cart that can do more things.

Thanks


--------------------
PMEmail Poster
Top
andy
Posted: Dec 17 2003, 12:39 PM
Quote Post





Group: Advantagecom Staff
Posts: 4,340
Member No.: 9
Joined: 12-July 02



QUOTE
So can I assume if I want to use my installed SSL certificate I need to put files in the https directory to be seen.


Yes, but to clarify, only non-cgi documents go in the httpsdocs directory. All cgi-bin needs to go in the cgi-bin directory ( /cgi-bin , not /httpdocs/cgi-bin or /httpsdocs/cgi-bin ). CGI that you put in the cgi-bin directory can be accessed with both https:// and http:// URLs.


--------------------
Sincerely,
Andrew Kinney
CTO, Advantagecom Networks

Please do not private message me. My regular management duties preclude responding to every customer that sends me a support issue. Instead, post on the forum or contact tech support.
PMUsers Website
Top
nels
Posted: Dec 17 2003, 06:51 PM
Quote Post





Group: Members
Posts: 44
Member No.: 341
Joined: 22-November 03



YEA NOPCART now works again, thanks for the help.

Now the next thing is to start using SSL and then fix my bug that charges everybody Ohio sales tax!...OOPS biggrin.gif

Nels


--------------------
PMEmail Poster
Top
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll